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R2012b+
Version: 2.7.10
New Features: No
Bug Fixes: No
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R2012b+

Second-Order Integrator Conversion

The SB2SL translator now converts second-order ntegrator blocks in the
SystemBuild™ model to the native Simulink® Second-Order Integrator block.
This change improves efficiency of generated code and performance, such
as efficient detection of zero crossings and prevention of direct feedthrough
and algebraic loops. In previous releases, the translator converted these
SystemBuild blocks to the SB2SL NthOrder1 block with the Order of
Integration parameter set to 2.
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R2012a+
Version: 2.7.9
New Features: No
Bug Fixes: No

No New Features or Changes
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R2011b+
Version: 2.7.8
New Features: Yes
Bug Fixes: No
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R2011b+

Trigonometric Blocks Now Converted to Algebraic
Equivalents

The SB2SL translator now converts SystemBuild model trigonometric blocks
to the algebraic equivalent of their compound trigonometric functions. This
change improves efficiency of generated code and performance. In previous
releases, the translator converted these SystemBuild model blocks to
combinations of native Simulink trigonometric functions.
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Translator Options Tab

Translator Options Tab

The View report after report creation check box on the SB2SL: Translator
Options > Report Format tab is now enabled only when the Format parameter
is set to Web (HTML). In previous releases, this check box was always enabled.
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R2011a+
Version: 2.7.7
New Features: No
Bug Fixes: No

No New Features or Changes
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R2010b+
Version: 2.7.6
New Features: Yes
Bug Fixes: No
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R2010b+

Support for the Simulink For Each Subsystem Block

The SB2SL translator now supports the Simulink For Each Subsystem within
the limitations of that subsystem.
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Saving and Restoring the Complete SimState

Saving and Restoring the Complete SimState

Use the SimState feature to save the complete simulation state. Unlike the
final states stored in earlier versions of Simulink, the SimState contains
the complete simulation state of the model (including block states that are
logged). You can then restore the state at a later time and continue simulation
from the exact instant at which you stopped the simulation. See Saving and
Restoring the Simulation State as the SimState in the Simulink User’s Guide.
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R2010a+
Version: 2.7.5
New Features: Yes
Bug Fixes: No
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R2010a+

ConstantAlgebraicExpression and
ConstantLogicalExpression Blocks Now Converted to
Simulink Constant Block

The SB2SL translator now converts SystemBuild model
ConstantAlgebraicExpression and ConstantLogicalExpression
blocks to the native Simulink Constant block. In previous releases, the
translator converted these SystemBuild model blocks to the Simulink
S-functions.
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Translator Options Dialog Box Change for Report Format Tab

Translator Options Dialog Box Change for Report
Format Tab

The SB2SL File > Preferences > Report Format tab View report after
conversion check box has changed:

• The new name is View report after report creation.

• Select this check box to display the report after it is created.
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R2010a+

Multiple Procedure Blocks with Same Name are Now
Converted

The SB2SL translator now converts multiple procedure blocks with the same
name. In previous releases, the translator was unable to convert multiple
procedure blocks with the same name.
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Printing from Tree View Behavior Changed

Printing from Tree View Behavior Changed

The SB2SL translator now prints the requested tree view for your model as
selected in the Window > Tree menu. In previous releases, the translator
reverted the view to Normal before printing.

19





R2009b+
Version: 2.7.4
New Features: Yes
Bug Fixes: No
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R2009b+

Translation Improvements

A number of translation improvements have been made to improve block
conversion results.
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R2009a+
Version: 2.7.3
New Features: Yes
Bug Fixes: No
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R2009a+

Translations Use Simulink Switch Block

The SB2SL translator now converts SystemBuild model switch blocks to the
native Simulink Switch block. In previous releases, the translator converted
SystemBuild model switch blocks to the SB2SL library Switch block.

The difference between the Simulink Switch block and its SystemBuild
counterpart is the order of the input ports. During translation, the SB2SL
translator converts to the Simulink Switch block port order.

The SB2SL library Switch block continues to exist for SystemBuild models
translated in previous releases.
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http://www.mathworks.com/help/releases/R2012a/toolbox/simulink/slref/switch.html


Translations Use Simulink® Integer Delay Block Where Appropriate

Translations Use Simulink Integer Delay Block Where
Appropriate

The SB2SL translator now converts SystemBuild model integer delay blocks to
the native Simulink Integer Delay block where appropriate. This substitution
occurs only if the SystemBuild model delays are integer values of the sample
time. If the SystemBuild model delays are noninteger values of the sample
time, the translator continues to use the SB2SL library DTimeDelay block.
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R2009a+

Translations Use Simulink Native Logic Blocks When
Requested

Upon request, the SB2SL translator now converts SystemBuild model
logic blocks to the native Simulink logic blocks where appropriate. This
substitution occurs only if you select SB2SL Preferences > Build and then
select the Logic blocks check box. See Translation Build Options in the
SB2SL User’s Guide.

26
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R2008b+
Version: 2.7.2
New Features: No
Bug Fixes: No

No New Features or Changes
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R2008a+
Version: 2.7.1
New Features: Yes
Bug Fixes: No
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R2008a+

Unified Translator Options and Windows Preferences
Dialog Boxes

The SB2SL translator options and windows preferences dialog boxes are now
consolidated on SB2SL File > Preferences. For further details, see Setting
Translation Options in the SB2SL User’s Guide.

In previous releases, the SB2SL translator options were located
in Build > Options and the windows preferences were located in
Windows > Preferences.
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New Save Button for User Preferences

New Save Button for User Preferences

The SB2SL Translator Options dialog box now has a Save button. Clicking
this button saves and applies your selections. The next time you restart
SB2SL, it loads the saved settings. In previous releases, you were not able
to save preferences. For further details, see Generating a Report in the
SB2SL User’s Guide.
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R2008a+

New Translation Build Options Check Box

The SB2SL File > Preferences > Translation Build Options tab contains
a new check box, Use round sum block. When you select this check box,
SB2SL uses a round summing junction instead of a square one in the Simulink
model. This is only a visual change. For further details, see Translation Build
Options in the SB2SL User’s Guide.
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Fixed Bugs

Fixed Bugs

This section lists fixes to bugs that occurred in the previous version of SB2SL.

Translation of Some Block IDs to Annotations Failed
In the previous release, there was an issue in the way that SB2SL handled
the translation of some block IDs to annotations. This is no longer an issue.
SB2SL can now translate all expected blocks.
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R2007b+
Version: 2.7
New Features: Yes
Bug Fixes: No
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R2007b+

Block Wiring Alignment Changes for Inports and
Outports

When SB2SL converts a National Instruments® SystemBuild model to a
Simulink model, it organizes the model blocks and the connections between
them using a predefined algorithm. In this release, SB2SL now converts the
models with the following conventions to improve block layout:

• Aligns inport blocks at the same height as the signal port that they drive

• Places inport blocks near the block port they connect to

• Staggers input blocks horizontally to prevent overlapping

• Aligns outport blocks at the same height as and within a fixed distance
of the signal port that drives them

• Staggers output blocks horizontally to prevent overlapping

• Uses duplicate inport blocks for multirouted inport signals instead of
routing multiple wires from a single port
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Naming Changes

Naming Changes

SB2SL now converts the names in SystemBuild models in the following way:

• SB2SL now names the top-level model for its corresponding SuperBlock.
This helps with component-based modeling. In previous releases, SB2SL
named the top-level model untitled.

• SB2SL now names converted subsystems for their SuperBlocks without
including the block ID in the block name. SB2SL now includes the block ID
in the 'AttributesFormatString' property of the Subsystem block (see
Default Conversion Results in the SB2SL User’s Guide).

• All inport blocks now follow the standard Simulink naming pattern InNN
instead of the previous input-NN pattern.

• Inport and Output block names no longer appear under the block by
default. To display the block name, select Format > Show Name for the
block. In previous releases, Inport and Output block names were displayed
under the blocks.

• All outport blocks now follow the standard Simulink naming pattern OutNN
instead of the previous output-NN pattern.

• SB2SL blocks now insert the block ID in the 'AttributesFormatString'
property of the block by default. The ID is still visible just below the block
name, but it is not part of the block name. See the Put IDs in annotations
build option in Translation Build Options of the SB2SL User’s Guide.

• For unnamed SystemBuild blocks, SB2SL provides a unique canonical
name in the Simulink environment (such as Sum, Product, and so forth)
and hides the name. To display the block name, select Format > Show
Name for the block.
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R2007b+

General Translation Changes

SB2SL has the following general translation changes:

• SB2SL now recognizes both the .sbd and .xmd file extensions. You can
open these as long as they are in the textual format. In previous releases,
SB2SL recognized only .xmd file extensions.

• SB2SL now enables the following:

- Code reuse (to support the Reusable function option of the Real-Time
Workshop system code parameter for subsystem blocks (see
“Nonvirtual Subsystem Code Generation Options” in the Real-Time
Workshop® User’s Guide.)

- Variable-step solvers in referenced models

- Improved performance with accelerated models

- Simulink Normal mode for model reference

These changes are for the following blocks in the SB2SL library:

1VarPoly
ConditionBlock
DAxisRotation
Decoder
Encoder
IAxisRotation
LogExpression
ZILogExpression
General
General0

• SB2SL now optionally converts the Condition block using native Simulink
if-else blocks and action subsystems for the Condition block Mode
parameter set to With Default and No Default. This change allows the
Simulink software to provide additional optimization and configuration
ability in simulation and code generation. See the Use native blocks if
possible build option in Translation Build Options of the SB2SL User’s
Guide.

• The following SB2SL Build menu translation options have been added:
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General Translation Changes

- Create SuperBlock libraries

- Use native blocks if possible

- Put IDs in annotations

• The SB2SL Build menu Avoid block crossing translation option has
been renamed to Route wires around blocks.

• SB2SL now converts procedure SuperBlocks to atomic subsystems.

• BlockScripts now support code generation, with the following limitations:

- BlockScripts that contain scalar parameters cannot generate embedded
real-time (ERT) target code.

- BlockScripts cannot be used in referenced models.
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R2007b+

Visual Changes

SB2SL has the following visual changes:

• If a SystemBuild blocks has its border option enabled, SB2SL no longer
converts that block with a drop shadow.

• SB2SL dialog boxes for error, query, and options now have improved fonts,
colors, layout, and interactivity.
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Fixed Bugs

Fixed Bugs

This section lists fixes to bugs that occurred in the previous version of SB2SL.

Selecting SuperBlocks for Conversion of Smaller SystemBuild
Models Was Not Possible
In a previous release, you could not select a SuperBlock in SB2SL and convert
just that block to a smaller SystemBuild model. This is no longer a problem.

SB2SL Cannot Convert SystemBuild Models that Contain Limiter
Functions with Particular Limits
SB2SL cannot convert SystemBuild models that contain limiter functions with
an upper limit parameter value that is less than the lower limit parameter
value. (The larger value is used for the upper limit parameter and the smaller
value is used for the lower limit parameter.) This is no longer a problem.
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